cabal installがうまくいかない…

a0002_009631

Haskellで遊んでいるのですが、ライブラリをインストールしようと「cabal install」しようとすると、なかなかうまくいかないことが多く…

$ sudo cabal install utf8-string
Password:
Resolving dependencies...
Configuring utf8-string-1...
Failed to install utf8-string-1
Build log ( /Users/XXXXXXX/.cabal/logs/utf8-string-1.log ):
cabal: Error: some packages failed to install:
utf8-string-1 failed during the configure step. The exception was:
user error ('/opt/local/bin/ghc' exited with an error:
: cannot satisfy -package-id
Cabal-1.22.0.0-d9247845ee9375b11bf2b8b2c2974972:
Cabal-1.22.0.0-d9247845ee9375b11bf2b8b2c2974972 is unusable due to missing or
recursive dependencies:
unix-2.7.0.1-8adde3f1f2079286da56b30898c2d703
(use -v for more information)
)

何かにつけて、依存先のunix-2.7.0.1のインストールに失敗、という状況で、対応方法もよくわからず…

とりあえず開発環境系の作業で躓くと、やる気が萎えますねぇ…

スポンサーリンク

フォローする

スポンサーリンク